Lenovo SEL Viewer 工具用户指南

前言

关于本手册

感谢您购买并使用英特尔® 服务器主板。此版本的实用程序支持

  • 英特尔® 服务器主板 S1200BT
  • 英特尔® 服务器主板 S1400
  • 英特尔® 服务器主板 S1600
  • 英特尔® 服务器主板 S2400
  • 英特尔® 服务器主板 S2600
  • 英特尔® 服务器主板 S4600

本手册面向负责故障排除、升级和维修该服务器主板的系统技术人员。系统事件日志(SEL)查看器用于显示、清除或保存服务器上的 SEL 日志。有关服务器的最新信息,请参阅 http://support.intel.com/support/motherboards/server/.

1. 简介

基板管理控制器(BMC)在闪存中的日志中记录有关系统事件的详细信息。每个 SEL 条目对应一个单一的系统事件。

SEL Viewer实用程序提供查看存储在服务器管理存储设备上的服务器系统事件记录的功能。该实用程序以文本或十六进制格式显示 SEL 记录。该实用程序还允许您将 SEL 条目保存到文件并从文件加载 SEL 条目以供查看。您还可以从服务器重新加载 SEL 条目并查看 SEL 条目的属性。SEL 条目可以两种模式查看:解释文本模式和十六进制模式。此版本的 SEL Viewer实用程序在以下操作系统上运行

操作系统 支持平台
UEFI 2.0 / 2.1S1200BT、S1400、S1600、S2400、S2600 和 S4600
Windows Server 2008 R2 SP1* x64S1200BT、S1400、S1600、S2400、S2600 和 S4600
Windows Server 2008 SP2* x64 和 x32S1200BT、S1400、S1600、S2400、S2600 和 S4600
Windows 7* x64 和 x32S1200BT、S1400、S1600、S2400、S2600 和 S4600 Workstation Server 平台
WinPE 3.0* x64 和 x32
SuSE* Linux Enterprise Server 11 SP1S1200BT、S1400、S1600、S2400、S2600 和 S4600
SuSE* Linux Enterprise Server 11 SP2S1200BT、S1400、S1600、S2400、S2600 和 S4600
Red Hat* Enterprise Linux 6 update 1 x64 和 x32S1200BT、S1400、S1600、S2400、S2600 和 S4600
Red Hat* Enterprise Linux 6 update 2 x64 和 x32S1200BT、S1400、S1600、S2400、S2600 和 S4600

注意: SELViewer 版本可能因平台而异。请下载支持您平台的受支持网站上的相应 SELViewer 版本和构建版本。同时请查阅发行说明以了解已知问题。

2. 使用 Intel® SEL Viewer

安装 Intel® SEL Viewer

要在 EFI 中安装 SEL Viewer 实用程序,,请执行以下操作:

1. 将 SEL Viewer 发布目录中用于 EFI 的所有文件复制到 USB 闪存驱动器,或创建可引导的 EFI CD。

2. 将可移动介质插入服务器。

3. 启动服务器,并在提示时按 F2 键进入 BIOS 设置。

4. 转到 Boot Manager 菜单,并选择引导到 EFI shell 的选项。

5. 在 EFI shell 提示符下,输入 fsn:,其中 n 是对应于包含 SEL Viewer 实用程序文件的设备的文件系统编号。

要在 Windows* 中安装 SEL Viewer 实用程序使用独立安装方式,请执行以下操作:

  • 先决条件

必须安装 Java* 运行时环境 (JRE)

1. 安装 JRE X32 版本以支持 WinPE 2.0 (32 位) OS,安装 JRE X64 版本以支持 WinPE 2.1 (EM64T) OS。在 USB 闪存驱动器上安装 JRE 应在相同版本的操作系统上进行,即对于 JRE x32 版本使用 Windows* 32 位 OS,对于 JRE x64 版本使用 Windows* 64 位 OS。

2. 在 Windows*/WINPE 中使用 "PATH=%PATH%;<>:\bin"(其中 <> 是 cmd 提示符中显示的 USB 目录,例如 D: 或 E: 等,或 java 的安装路径,例如 c:\Program Files\Java)设置 JRE 路径。

3. 在 USB 闪存驱动器上安装 JRE 以支持 WinPE 2.0 和 WinPE 2.1 时,更改安装目录为 USB 闪存驱动器(例如,g:\)。

4. 将实用程序发布位置中的所有文件和子目录复制到一个硬盘文件夹中。(例如,c:\Selview)

5. 打开命令提示符,并按如下所示切换到该目录

a. 对于 32 位 Windows*,进入文件夹 "c:\Selview\windows\x86\imbdriver"。

b. 对于 64 位 Windows*,进入文件夹 "c:\Selview\windows\x64\imbdriver"。

6. 执行 "install.cmd"。

7. 此安装脚本将安装 Intel IPMI 驱动程序;如果系统中已存在 Microsoft IPMI 驱动程序,则不会安装 Intel IPMI 驱动程序。

8. 要运行 SEL Viewer 实用程序,请打开命令提示符,并将目录更改为 selview.exe 文件所在的文件夹(例如,cd c:\Selview\windows\x86)。

现在您可以运行该实用程序。

要在 Linux* 中安装 SEL Viewer 实用程序

  • 先决条件

必须安装 Java* 运行时环境 (JRE)。

必须运行 XServer 才能使 Intel® SEL Viewer GUI 正常工作。

1. 将实用程序发布位置中的所有文件和子目录复制到一个硬盘文件夹中。(例如,/home/Selview/Linux)

2. 打开命令提示符,并切换到该目录(例如,cd /home/Selview/Linuxr)。

3. 运行 selview

现在您可以运行该实用程序。

启动 Intel® SEL Viewer

要启动 SEL Viewer, 请执行以下操作:

1. 启动到目标操作系统。

从包含 SEL Viewer 文件的目录中,使用以下语法在 EFI shell 中启动 SEL Viewer:

selview [/clear | {/save [文件名] [/hex]} | /h | /?] 注意:可用连字符 (-) 替换正斜杠 (/)。

示例:

selview

(这将启动 SEL Viewer的图形版本。)

selview /clear 
selview /save MyFileName /hex
selview /h

以解释文本格式查看 SEL 记录

1. 启动 SEL Viewer。

2. 图形显示将显示所有 SEL 条目。以下示例显示文本视图:

图 1:SEL 查看器文本视图
图 1:SEL Viewer文本视图

基于 EFI 的 SEL Viewer的主窗口基于多列显示窗格,如图 1 所示。它显示所有 SEL 记录以及用于选择实用程序中可用主要功能的下拉菜单。

请参阅图 2 中的 SEL Viewer主实用程序窗口 (Windows* 和 Linux 操作系统*)。交互式模式下信息显示默认格式为解释文本格式。

图 2:SEL Viewer 主窗口 (Windows* 和 Linux 操作系统*)
图 2:SEL Viewer 主窗口 (Windows* 和 Linux 操作系统*)

解释后的数据按以下几列显示:

  • 正在显示的系统事件序列号。从 1 开始,每个事件递增 1。该列标题为 "Num"。
  • 时间戳。
  • 传感器类型和编号。
  • 事件描述 1
  • 生成器 ID。

底部信息窗格显示突出显示的 SEL 条目的详细信息。使用箭头键向上或向下移动,或使用 Tab 键高亮显示菜单。在 Linux* 中,底部信息窗格包含一个统计面板,其中包含基于事件类型 (严重、警告、信息和其它) 的事件统计表。

  • 1 基于 IPMI 规范,BIOS EPS

有关使用菜单项的信息,请参阅“查看 Intel® SEL Viewer 信息窗口”部分。

以十六进制格式查看 SEL 记录

使用 查看菜单用于选择 SEL 条目的显示方式(原始十六进制格式或纯文本)。选择原始十六进制格式以 HEX 格式查看 SEL 记录。

以下屏幕显示 Hex 格式中 SEL 日志的示例。

图 3:Hex 格式的 SEL 日志(EFI)
图 3:Hex 格式的 SEL 日志(EFI)

下图显示 Windows*和 Linux OSes*中的 SEL 记录(Hex 格式):

Lenovo SEL Viewer 工具用户指南
图 4:Hex 格式的 SEL 记录(Linux*)
图 4:Hex 格式的 SEL 记录(Linux*)

原始 Hex 显示中使用的缩写如下表所示:

缩写 描述
RID记录 ID
RT记录类型
TS时间戳
GID生成器 ID
ER事件消息格式修订版
ST传感器类型
SN传感器编号
EDIR事件方向和事件类型
ED1, ED2, ED3事件数据
MID制造商 ID
OEMOEM 定义
ExB1…ExB8扩展字节 1 … 扩展字节 8(仅支持 S1400、S1600、S2400、S2600 和 S4600 服务器平台。)

查看 Intel® SEL Viewer信息窗口

此选项允许您查看/隐藏 SEL 信息窗口。运行实用程序时,默认情况下 SEL 信息窗口可见,子菜单显示为“隐藏 SEL 信息窗口”。如果选择“隐藏 SEL 信息窗口”,SEL 信息窗口将从显示区域移除,且子菜单文本更改为“查看 SEL 信息窗口”。用户可以使用此子菜单再次添加 SEL 信息窗口。“隐藏 SEL 信息窗口/查看 SEL 信息窗口”选项目前在基于 EFI 的 SEL Viewer实用程序的十六进制视图中被禁用。当从文本视图切换到十六进制视图时,SEL 信息窗口会自动关闭。在 Linux* 情况下,此选项位于 SEL 菜单项下。

导航 Intel® SEL Viewer窗口

要导航 SEL Viewer窗口,请从下拉菜单中使用箭头键在各个菜单项之间移动,并使用<Enter>键选择特定菜单项。此外,对于基于 WinPE* 的 SEL Viewer实用程序,使用<Alt>键选择菜单,使用箭头键在各个菜单项之间移动,并使用<Enter>键选择特定菜单项。在基于 WinPE* 的 SEL Viewer实用程序中,还可使用<Alt-F>打开文件菜单项,<Alt-S>打开 SEL 菜单,<Alt-V>打开查看菜单,<Alt-H>打开帮助菜单。在基于 WinPE* 的 SEL Viewer实用程序中,可以通过在菜单项上左击鼠标来访问菜单项。对于基于 EFI 的 SEL Viewer实用程序,选中的菜单项的简要帮助消息会显示在提示查看窗口中,该窗口显示在主窗口的底部。此功能在基于 WinPE* 的 SEL Viewer实用程序中不受支持。对于基于 EFI 的 SEL Viewer实用程序,使用<Tab>键在显示窗格、底部的信息窗口和下拉菜单之间移动。

显示窗格支持箭头键、<PgDn>、<PgUp>、<Home>和<End>键以在显示窗格中移动。在基于 WinPE* 的 SEL Viewer实用程序中,<Home>键选择第一条记录,<End>键选择最后一条记录。在基于 EFI 的 SEL Viewer实用程序中,<HOME>键选择显示窗格中选定的 SEL 条目的开头,<END>键选择显示窗格中选定的 SEL 条目的结尾。基于 EFI 的 SEL Viewer实用程序支持<F5>键在各列之间向前移动,<F6>向后移动。使用左箭头键向左滚动,右箭头键向右滚动显示窗格。

首次调用实用程序时,它将从服务器的非易失性存储中加载 SEL 记录。显示如图 5:状态框所示的状态框,以指示 SEL Viewer正在从服务器加载 SEL 记录。在 Linux* 情况下,状态消息将显示在实用程序主窗口的状态栏上。

Lenovo SEL Viewer 工具用户指南

在 Windows* 和 Linux* SEL Viewer实用程序中,序列号可根据 SEL 事件的严重性进行颜色编码。此功能目前仅在 Windows* 和 Linux* 上可用。右下角提供了一个小面板,其中包含 SEL 记录的统计视图。它包含根据严重性类型(即信息、警告、严重和其他)分类的 SEL 事件计数。此功能目前也仅在 Windows* 和 Linux* 上可用。

将 Intel® SEL 保存到文件

您可能希望将 SEL 保存到文件以便进行分析、记录保存或系统问题的文档化。

有两种方法可以将 SEL 保存到文件(本示例显示 Windows* 预启动环境 *版本):

  • 要保存 SEL,请使用以下命令行语法:
    在解释文本格式下 - selview /save MyFileName
    在十六进制格式下 - selview /save MyFileName /hex
  • 使用File | Save菜单选项从图形 SEL Viewer窗口。

要将 SEL 数据保存到具有".sel"文件扩展名的文件中,无论是解释文本格式还是原始十六进制格式,取决于当前显示的记录模式。

从文件查看 Intel® SEL

要查看之前已保存到文件的 SEL 记录,请使用File | Open菜单选项从图形 SEL Viewer窗口。

要返回到从非易失性内存查看 SEL 记录,请使用SEL | Reload菜单选项。

检查 Intel® SEL 属性(条目数、添加/擦除时间和可用空间)

要在 SEL 属性对话框中检查 SEL 属性,请使用SEL | Properties菜单选项从图形 SEL Viewer窗口。

图 6:SEL 属性对话框
图 6:SEL 属性对话框

注意事项:

  • SEL Viewer 将以字节为单位显示 Free Space Remaining(剩余可用空间)。
  • 在 Linux* 中,SEL 属性对话框将不显示 Last Add Time 和 Last Erase Time。

清除 Intel® SEL

SEL 容量有限。有关服务器最大记录数的信息,请参阅服务器主板产品指南中的规格说明。当 SEL 已满时,后续系统事件将不会被记录,您需要手动清除 SEL。有两种方法可以清除 SEL(本示例以 Windows* 预启动环境版本为例):

  • 使用命令行语法:selview /clear
  • 使用 SEL | Clear菜单选项来自图形化 SEL Viewer窗口。

在 UI 中排序 Intel® SEL 条目

使用 SEL| Sort by选项在 SEL Viewer主窗口中,按不同字段对 SEL 条目进行排序。选择此选项后,将显示可用于排序的字段列表。您可以按 Num、Time Stamp、Sensor Type and Number、Event Description 和 Generator ID 对记录进行排序。选择相应字段后,即按该字段进行排序。如果 SEL 条目以十六进制模式显示,则此选项不可用。对于基于 Windows*/Linux* 的 SEL Viewer实用程序,也可以通过鼠标点击相应的列标题来执行排序(在文本模式显示的情况下)。

Go To 选项(仅限 Linux* 功能)

在 SEL Viewer主窗口中使用 SEL | Go To 选项,根据序列号选择特定的 SEL 条目。用户可在“转到”对话框提供的文本框中输入 SEL 条目的序列号,SEL 表将在实用程序主窗口中滚动,并高亮显示该特定条目。“转到”功能可通过快捷键 CTRL+G 访问。此功能目前仅支持 Windows* 和 Linux*。

获取额外帮助

如果您需要有关命令行语法或本用户指南未描述的任一图形化菜单项的帮助,请使用在线帮助。获取帮助有两种方式:

使用命令行语法:selview /help

  • 使用 Help 菜单选项(位于图形化 SEL Viewer 窗口中)。

卸载 Intel® SEL Viewer

要在 EFI 中卸载 SEL Viewer实用程序,请执行以下操作:

1. 在命令行提示符中进入所有实用程序文件从实用程序发布位置复制到的目录

2. 在命令行提示符下运行'cd ..'。这将带您进入上一级目录。

3. 删除当前目录中的所有目录,包括子目录。这将导致实用程序文件的卸载。

要在 Windows* 中卸载 SEL Viewer Utility,请执行以下操作:

如果是独立安装的,应手动删除实用程序文件

1. 在命令行提示符中进入所有实用程序文件从实用程序发布位置复制到的目录

2. 在命令行提示符下运行'cd ..'。这将带您进入上一级目录。

3. 删除当前目录中的所有目录,包括子目录。这将导致实用程序文件的卸载。

要在 Linux* 中卸载 SEL Viewer Utility,请执行以下操作:

1. 在命令行提示符中进入所有实用程序文件从实用程序发布位置复制到的目录

2. 在命令行提示符下运行'cd ..'。这将带您进入上一级目录。

3. 删除当前目录中的所有目录,包括子目录。这将导致实用程序文件的卸载。

附录 A. 退出错误代码

SEL Viewer 的命令行版本可用于脚本中,以自动化保存 SEL、清除 SEL 或搜索 SEL 的任务。以下退出代码列表可能对脚本中的错误处理部分有用。

整数值 解释
0成功终止。
1无法清除 SEL。
2SEL 日志为空。
3无法读取 SEL 条目。
4无法创建 SEL 文件。
5调用无效。
6IPMI 驱动程序初始化失败
7无法初始化 SEL Viewer
8未知错误。
6 次浏览 更新于 2026-11-07

同组文章服务器日志与告警判读

查看本组全部 15 篇

没有找到想要的答案?

上传日志让 AI 帮你诊断,或者在控制台里直接向 AI 提问。